Subject: VM 6.05 freezes in the middle of downloading mail

From: Kyle Jones <[email-masked]>
Date: Sun, 26 Jan 1997 01:03:39 -0500 (EST)

jeffrey covey writes:
 > i've been having a very frustrating problem with vm for about
 > a week.  sometimes it works perfectly, but at least once a day
 > i try to download the mail from my pop server and vm just
 > freezes.

Late last month Bill Carpenter reported that VM's pop client
tends to make ntemacs exhaust memory with retrieving large
messages, probably due to the heap being excessively fragmented.
Emacs might seem frozen while it thrashes memory.

 > i telnet in, and when i open pine i just see one
 > message.  this is a snapshot of it from when i presented the
 > problem to my systems people (they didn't know what to do):
 > 
 > N  1 Jan 22 [email-masked]  (220k) /umbc/general/v17/jcovey1/.mailspool
 > 
 > (the display is trimming off the last bit, "/jcovey1").
 > 
 > when i open it, i have a mountain of messages listed one after
 > the other (as though i'd just piped a mail folder through
 > more).  once i move the jcovey1 file out of .mailspool, all is
 > well again.  also, a file of 0 length named .jcovey1.pop has
 > appeared in .mailspool; i've never seen it before.

This seems unrelated to Emacs or VM.  Best guess would be that
whatever it is that's delivering mail into your mailbox, or
perhaps whatever it is that's assembling a mailbox for the POP
server's use isn't always putting the correct message separators
between the messages.  The POP server sees one gigantic message
(as does pine) and sends it to VM as such.  VM tries to handle
it, fragments the heap and brings Emacs to its knees.

I have no solution.  Bill Carpenter's solution was to insert
delays into VM's POP read loop, which caused it to retrieve
larger chunks of data from the server per iteration, which
reduced heap fragmentation.  I'm not happy about making a pretty
slow POP client even slower, so I'm hoping a better idea will
come to me.  It hasn't so far.

---

From: [email-masked] (jeffrey covey)
Date: Sat, 25 Jan 1997 22:11:55 -0500 (EST)

i've been having a very frustrating problem with vm for about a week.
sometimes it works perfectly, but at least once a day i try to
download the mail from my pop server and vm just freezes.  i telnet
in, and when i open pine i just see one message.  this is a snapshot
of it from when i presented the problem to my systems people (they
didn't know what to do):

when i open it, i have a mountain of messages listed one after the other (as 
though i'd just piped a mail folder through more).  once i move the
jcovey1 file out of .mailspool, all is well again.  also, a file of 0
length named .jcovey1.pop has appeared in .mailspool; i've never seen
it before.

so at least once a day i have to catch this happening and jump in
there and move the file and mail it to myself so i can take it apart
here and see what's in it.

any ideas?  it's a real drag...
thanks!

Emacs  : GNU Emacs 19.34.1 (i386-*-nt4.0) of Thu Aug 29 1996 on BANANA-FISH
Package: VM 6.05

current state:
==============
(setq
 vm-arrived-message-hook nil
 vm-arrived-messages-hook nil
 vm-auto-center-summary nil
 vm-auto-decode-mime-messages nil
 vm-auto-displayed-mime-content-types '("text")
 vm-auto-folder-case-fold-search nil
 vm-auto-get-new-mail nil
 vm-auto-next-message t
 vm-berkeley-mail-compatibility nil
 vm-check-folder-types t
 vm-circular-folders 0
 vm-confirm-new-folders nil
 vm-confirm-quit 0
 vm-convert-folder-types t
 vm-crash-box "~/INBOX.CRASH"
 vm-default-folder-type 'From_
 vm-delete-after-archiving t
 vm-delete-after-bursting nil
 vm-delete-after-saving t
 vm-delete-empty-folders t
 vm-digest-burst-type "guess"
 vm-digest-identifier-header-format "X-Digest: %s\n"
 vm-digest-center-preamble t
 vm-digest-preamble-format "\"%s\" (%F)"
 vm-digest-send-type "rfc934"
 vm-display-buffer-hook nil
 vm-display-using-mime t
 vm-edit-message-hook nil
 vm-edit-message-mode 'text-mode
 vm-flush-interval t
 vm-folder-directory "~/mail/"
 vm-folder-read-only nil
 vm-follow-summary-cursor t
 vm-forward-message-hook nil
 vm-forwarded-headers nil
 vm-forwarding-digest-type "rfc934"
 vm-forwarding-subject-format "forwarded message from %F"
 vm-frame-parameter-alist nil
 vm-frame-per-completion t
 vm-frame-per-composition t
 vm-frame-per-edit t
 vm-frame-per-folder t
 vm-frame-per-summary nil
 vm-highlight-url-face 'bold-italic
 vm-highlighted-header-regexp nil
 vm-honor-page-delimiters nil
 vm-in-reply-to-format "%i"
 vm-included-text-attribution-format "%F writes:\n"
 vm-included-text-discard-header-regexp nil
 vm-included-text-headers nil
 vm-included-text-prefix " > "
 vm-inhibit-startup-message nil
 vm-init-file "~/.vm"
 vm-invisible-header-regexp nil
 vm-jump-to-new-messages t
 vm-jump-to-unread-messages t
 vm-keep-crash-boxes nil
 vm-keep-sent-messages 1
 vm-mail-header-from nil
 vm-mail-hook nil
 vm-mail-mode-hook '(set-mail-archive-file-name sq-quote-setup)
 vm-mime-alternative-select-method 'best-internal
 vm-mime-button-face 'bold-italic
 vm-mime-base64-decoder-program nil
 vm-mime-base64-decoder-switches nil
 vm-mime-base64-encoder-program nil
 vm-mime-base64-encoder-switches nil
 vm-mime-external-content-types-alist nil
 vm-mime-internal-content-types t
 vm-mode-hook '((lambda nil (local-set-key "r" (quote vm-followup))
		 (vm-fontify))
		)
 vm-mode-hooks nil
 vm-mosaic-program "Mosaic"
 vm-move-after-deleting t
 vm-move-after-undeleting nil
 vm-move-messages-physically nil
 vm-movemail-program "movemail"
 vm-mutable-frames nil
 vm-mutable-windows t
 vm-netscape-program "netscape"
 vm-options-file "~/.vm.options"
 vm-pop-md5-program "md5"
 vm-popup-menu-on-mouse-3 t
 vm-preview-lines 0
 vm-preview-read-messages nil
 vm-primary-inbox "~/INBOX"
 vm-quit-hook nil
 vm-recognize-pop-maildrops "^[^:]+:[^:]+:[^:]+:[^:]+:[^:]+"
 vm-reply-hook nil
 vm-reply-ignored-addresses nil
 vm-reply-ignored-reply-tos nil
 vm-reply-subject-prefix nil
 vm-resend-bounced-discard-header-regexp nil
 vm-resend-bounced-headers '("Resent-" "From:" "Sender:" "Reply-To:" "To:"
			     "Cc:" "Subject:" "Newsgroups:" "In-Reply-To:"
			     "References:" "Keywords:" "X-")
 vm-resend-bounced-message-hook nil
 vm-resend-discard-header-regexp "\\(\\(X400-\\)?Received:\\|Resent-\\)"
 vm-resend-headers nil
 vm-resend-message-hook nil
 vm-retrieved-spooled-mail-hook nil
 vm-rfc1153-digest-discard-header-regexp "\\(X400-\\)?Received:"
 vm-rfc1153-digest-headers '("Resent-" "Date:" "From:" "Sender:" "To:" "Cc:"
			     "Subject:" "Message-ID:" "Keywords:")
 vm-rfc934-digest-discard-header-regexp nil
 vm-rfc934-digest-headers '("Resent-" "From:" "Sender:" "To:" "Cc:"
			    "Subject:" "Date:" "Message-ID:" "Keywords:")
 vm-search-using-regexps nil
 vm-select-message-hook nil
 vm-select-new-message-hook nil
 vm-select-unread-message-hook nil
 vm-send-digest-hook nil
 vm-send-using-mime t
 vm-skip-deleted-messages t
 vm-skip-read-messages nil
 vm-startup-with-summary t
 vm-strip-reply-headers nil
 vm-summary-format "%n %*%a %-15.15F [%-3.3w %-3.3m %2d] (%4l) %I %s\n"
 vm-summary-highlight-face 'bold
 vm-summary-mode-hook nil
 vm-summary-mode-hooks nil
 vm-summary-redo-hook nil
 vm-summary-show-threads nil
 vm-summary-subject-no-newlines t
 vm-summary-thread-indent-level 2
 vm-summary-uninteresting-senders nil
 vm-summary-uninteresting-senders-arrow "To: "
 vm-tale-is-an-idiot nil
 vm-temp-file-directory "/tmp"
 vm-trust-From_-with-Content-Length nil
 vm-undisplay-buffer-hook nil
 vm-unforwarded-header-regexp "only-drop-this-header"
 vm-url-browser 'vm-mouse-send-url-to-netscape
 vm-url-search-limit 12000
 vm-use-menus nil
 vm-use-toolbar '(next previous delete/undelete autofile file reply compose
		  print visit quit nil help)
 vm-virtual-folder-alist nil
 vm-virtual-mirror t
 vm-visible-headers '("Resent-" "From:" "Sender:" "To:" "Apparently-To:"
		      "Cc:" "Subject:" "Date:")
 vm-visit-folder-hook nil
 vm-visit-when-saving 0
 vm-warp-mouse-to-new-frame nil
 vm-window-configuration-file "~/.vm.windows"
 features '(reporter electric bbdb-com bbdb-vm bbdb t appt diary-lib
	    cal-china lunar solar cal-dst cal-islam cal-julian cal-hebrew
	    holidays cal-move calendar cal-menu fdb rsz-mini avoid delsel
	    pc-select fold-isearch folding advice advice-preload
	    generic-extras generic-mode mailabbrev tapestry vm-window
	    vm-virtual vm-version vm vm-vars vm-undo vm-toolbar vm-thread
	    vm-startup vm-summary vm-sort vm-search vm-save vm-reply vm-pop
	    vm-page vm-motion vm-mouse vm-misc vm-minibuf vm-mime vm-message
	    vm-menu vm-mark vm-license vm-folder vm-edit vm-easymenu
	    vm-digest vm-delete sig-quote mini-cl cl cl-19 rnews mail-utils
	    smtpmail sendmail env paren timer font-lock hilit19 ediff-hook
	    vc-hooks lisp-float-type disp-table ls-lisp lisp-mode page
	    menu-bar select scroll-bar mouse facemenu faces frame)
 )

unsolicited commercial e-mail will be billed at $250/message.