Subject: Problems with menu-bar-mode and scroll-bar-mode?

From: Michael Hotchin <[email-masked]>
Date: Sun, 22 Dec 1996 17:48:41 -0800

The docs for these two functions indicate that they apply both to
current frames and
alll subsequent frames.  However, when I use them, new frames ignore
them. I'm running:

GNU Emacs 19.34.1 (i386-*-nt4.0) of Wed Aug 28 1996 on BANANA-FISH

on:

NT 4.0 build 1381 Service pack 2.

Are there any known problems with these two functions?  I don't have a
non-NT system,
so I can't try them on an X system to see if this is an NT specific
problem or more 
widespread.

I invoke them thusly:

;;  The last thing EMACS needs is menus...
(menu-bar-mode -1)
(scroll-bar-mode -1)

I have a work-around for the scroll-bars - I just put this in
"default-frame-alist':
	(horizontal-scroll-bars . nil)
	(vertical-scroll-bars . nil)

However, the menu mode is more tenacious.

In any case, the docs indicate that I shouldn't need this at all.

	Mike H.

---

From: Ivan Ganza <[email-masked]>
Date: Mon, 23 Dec 1996 01:22:24 -0500

> ;;  The last thing EMACS needs is menus...
Setting menu-bar-mode to 0 works for me.  I am on NT 4.0. 

-Ivan