Subject: Re: Greetings and question about ~

From: Milt Epstein <[email-masked]>
Date: Tue, 24 Sep 1996 08:49:22 -0500 (CDT)

On Tue, 17 Sep 1996, Milt Epstein wrote:

> Hi.  I've been using ntemacs for about a month now, and I just
> subscribed to this list.  So I might bombard the list with a bunch of
> questions over the next week or so as I try to get a bunch of things
> resolved :-).
> 
> Firstly, it looks like I'm having problems with my setting of "~".
> For example, when I evaluate (e.g. in *scratch*):
> 
> (expand-file-name "~")
> 
> I get:
> 
> "c:/users/milte/users/milte/"
> 
> But when I try:
> 
> (expand-file-name "~/emacs")
> 
> I get:
> 
> "c:/users/milte/emacs"
[ ... ]

I didn't really get any response on this.  Could maybe a few people at
least try this to see whether they get similar problematic output?
Thanks.

Milt Epstein
Software Engineer
Central Data Corporation
[email-masked]
WWW: http://www.cd.com/
FTP: ftp.cd.com

---

From: Andrew Innes <[email-masked]>
Date: Tue, 24 Sep 1996 18:00:14 +0100

On Tue, 17 Sep 96 12:05:43 CDT, [email-masked] (Milt Epstein) said:
>(getenv "HOME")
>returns:
>"\\users\\milte\\"
>I'm using tcsh, if that matters.
>
>Anyone know what's going on here?  I'd like my "~" back.
>Thanks.

You need to set HOME to be a fully-qualified pathname.  In particular,
you are missing a drive letter.  Without that, expand-file-name gets a
bit confused, and gives unusual results as you've noticed.

AndrewI

PS. It might also be that you're using an older version of Emacs - in
19.31 a number of bugs in expand-file-name were fixed.