Subject: Re: hyperbole with mouse

From: Mats Lidell <[email-masked]>
Date: 29 Dec 1996 00:22:37 +0100

>>>>> "Antoine" == Antoine Bertier <[email-masked]> writes:

    Antoine> Anyone using hyperbole with NTEmacs ?

Yes. Three things I have changed below.

Environment: Emacs-19.34, NT 4.0

(Patch begin)
--------------------
1) Window system is win32. This is essential for the hyperbole actions
   to work.

*** hversion.el	Fri Nov 08 20:46:47 1996
--- hversion.el.~1~	Sat Nov 04 05:08:26 1995
***************
*** 71,77 ****
  (defun sm-window-sys-term ()
    "Returns the first part of the term-type if running under a window system, else nil.
  Where a part in the term-type is delimited by a '-' or  an '_'."
!   (let ((term (cond ((memq window-system '(x ns dps pm win32))
  		     ;; X11, NEXTSTEP (DPS), or OS/2 Presentation Manager (PM)
  		     (cond (hyperb:emacs19-p "emacs19")
  			   (hyperb:lemacs-p  "lemacs")
--- 71,77 ----
  (defun sm-window-sys-term ()
    "Returns the first part of the term-type if running under a window system, else nil.
  Where a part in the term-type is delimited by a '-' or  an '_'."
!   (let ((term (cond ((memq window-system '(x ns dps pm))
  		     ;; X11, NEXTSTEP (DPS), or OS/2 Presentation Manager (PM)
  		     (cond (hyperb:emacs19-p "emacs19")
  			   (hyperb:lemacs-p  "lemacs")

--------------------
2) Not essential but if you have HOME defined you want the user global
   buttons to be located there.

*** hbmap.el	Wed Nov 13 09:20:08 1996
--- hbmap.el.~1~	Tue Oct 24 23:32:06 1995
***************
*** 114,121 ****
  ;;; ************************************************************************
  
  (defvar hbmap:dir-user
!   (if (and (memq system-type '(ms-windows windows-nt ms-dos))
! 	   (not (getenv "HOME")))
        "c:/_hyperb/" "~/.hyperb/")
    "Per user directory in which to store top level Hyperbole map data.
  Must end with a directory separator.
--- 114,120 ----
  ;;; ************************************************************************
  
  (defvar hbmap:dir-user
!   (if (memq system-type '(ms-windows windows-nt ms-dos))
        "c:/_hyperb/" "~/.hyperb/")
    "Per user directory in which to store top level Hyperbole map data.
  Must end with a directory separator.

--------------------
3) Well this shouldn't be necessary at all but seems like gnuspost
   isn't here any more at least not for me. The GNUS support within
   hyperbole seems to work fine anyway (at least the part I use ;-)

*** hgnus.el	Fri Nov 08 18:37:55 1996
--- hgnus.el.~1~	Tue Aug 08 15:53:46 1995
***************
*** 42,48 ****
  
  (require 'hmail)
  (require 'hsmail)
! ;; -ml (require 'gnuspost)
  
  ;;; ************************************************************************
  ;;; Public variables
--- 42,48 ----
  
  (require 'hmail)
  (require 'hsmail)
! (require 'gnuspost)
  
  ;;; ************************************************************************
  ;;; Public variables

--------------------
(Patch over)

%% Mats

---

From: Mats Lidell <[email-masked]>
Date: 17 Feb 1997 22:21:02 +0100

>>>>> I wrote:

Mats> Yes. Three things I have changed below.

OOPS! One more thing that is needed which I forgot to tell
you about. Hyperbole needs the timezone (but I have no patch just how
I solved it.)

In the file htz.el the variable htz:local is initialized either by
getting it from the environment or calling the program "date" and
parsing its output. Neither of these approaches works out of the box
on NT.

I solved it by adding

	(setenv "TZ" "MET")

in my .emacs. (which is the reason I forgot to include it in the patch
I supplied earlier. I'm really sorry.)

%% Mats