Subject: Re: pgp and mailcrypt

From: "Scott C. Johnson" <[email-masked]>
Date: Tue, 21 Jan 1997 02:25:29 -0600

Howard Melman wrote:
> 
> Has anyone gotten PGP and mailcrypt to work?  I have PGP
> 2.6.2 and I think it's working.  I've used mailcrypt before
> and have the same version 3.4 that used to work for me on
> Unix working with VM 5.96.  I'm trying to put a copy of my
> public key into a message via `C-c / x' but pgp exits with a
> status of 13.  I don't know how to look up what that status
> code means.  If I issue the pgp command on the command line
> it works fine, so I assume it's some problem with running
> pgp in batchmode or how it interfaces with Emacs.
> 
> I have the same problem on both Win95 and NT 4.0.
> 
> Howard
I have gotten PGP and mailcrypt to work with some modifications. There
are a some hooks into the unix version that you have to disable. My main
problem was that the dos command line was getting messed up by all of
the configuration options. 

As far as I can tell, DOS can only handle 120 characters and mailcrypt
calls the dos pgp. The options were too long and got truncated when
running the pgp dos command. I got around that by deleting the extra
configuration options in the *.el files and setting them in the
config.txt instead. 

Scott

---

From: Howard Melman <[email-masked]>
Date: Tue, 21 Jan 1997 09:27:57 -0500

I managed to get a win-32 version of pgp.exe.  Though I
still got the same "pgp exited with a status of 13" messages
when trying to insert my public key in a mail message.  When
looking at the *MailCrypt* buffer I saw pgp was trying to
find a keyring called mailcrypt.pgp.

The solution was to add

  (setq win32-quote-process-args t)

to my .emacs.  I don't yet know if it will break anything
else I run.  It's hasn't in a half day or so.

Also note, that I after setting this I could use the DOS
version of pgp.exe to insert my public key in a message but
neede the win-32 to decrypt or encrypt a message.

I'm running on NT 4.0.

Thanks for all the help everyone.  It would be VERY GOOD if
someone who built a win-32 version could get a copy to 
Jeff Schiller to include in the MIT distribution site.  I
don't feel comfortable doing it not having built it myself
(or even completely understanding the difference between a
DOS and win-32 program and why it matters here).

Howard