Subject: Core dump with ffap.

From: "William Sobel" <[email-masked]>
Date: Tue, 12 Nov 1996 08:40:47 -0500

I have just loaded and setup ffap. I then bound it to a mouse button.
When I clicked on the a file name it works find, but when I click on
something which is not a file name it crashes emacs with a memory
exception tring to access 0x0000004.

Thanks for any help,
Will

-- 

*    William Sobel               Redpoint Software, Inc.      *
*    SVP Technology              110 Fieldcrest Ave.          *
*    http://www.rpsi.com/        Raritan Center I, 4th Floor  *
*    [email-masked]            Edison, NJ 08837             *

---

From: "William Sobel" <[email-masked]>
Date: Wed, 13 Nov 1996 12:53:01 -0500

The backtrace from the core dump is as follows:

win32_mouse_position() line 1750 + 8 bytes
Fx_popup_menu() line 1164 + 30 bytes
Ffuncall() line 2366 + 24 bytes
Fbyte_code() line 408 + 14 bytes
funcall_lambda() line 2544 + 41 bytes
Ffuncall() line 2403 + 20 bytes
Fbyte_code() line 408 + 14 bytes
funcall_lambda() line 2544 + 41 bytes
Ffuncall() line 2403 + 20 bytes
Fcall_interactively() line 675 + 17 bytes
Ffuncall() line 2370 + 31 bytes
Fbyte_code() line 408 + 14 bytes
funcall_lambda() line 2544 + 41 bytes
Ffuncall() line 2403 + 20 bytes
Fcall_interactively() line 675 + 17 bytes
Fcommand_execute() line 6904 + 17 bytes
command_loop_1() line 1371 + 29 bytes
internal_condition_case() line 1132 + 3 bytes
command_loop_2() line 994 + 21 bytes
internal_catch() line 907 + 7 bytes
command_loop() line 974 + 22 bytes
recursive_edit_1() line 755 + 5 bytes
Frecursive_edit() line 798
main() line 1004
mainCRTStartup + 196 bytes
_start() line 119

I was wundering if anyone can make any sense out of this. I do not 
currently have source but I would be interested if anyone knows this
code or why it could fail.

The actions once again are to load ffap

(require 'ffap)
(ffap-bindings)
(global-set-key [C-mouse-1] 'ffap-at-mouse)

C-Click on some random text and you get the message that adddress
0xC0000005 could not be accessed.

Thanks for help,
Will

-- 

*    William Sobel               Redpoint Software, Inc.      *
*    SVP Technology              110 Fieldcrest Ave.          *
*    http://www.rpsi.com/        Raritan Center I, 4th Floor  *
*    [email-masked]            Edison, NJ 08837             *
win32_mouse_position() line 1750 + 8 bytes
Fx_popup_menu() line 1164 + 30 bytes
Ffuncall() line 2366 + 24 bytes
Fbyte_code() line 408 + 14 bytes
funcall_lambda() line 2544 + 41 bytes
Ffuncall() line 2403 + 20 bytes
Fbyte_code() line 408 + 14 bytes
funcall_lambda() line 2544 + 41 bytes
Ffuncall() line 2403 + 20 bytes
Fcall_interactively() line 675 + 17 bytes
Ffuncall() line 2370 + 31 bytes
Fbyte_code() line 408 + 14 bytes
funcall_lambda() line 2544 + 41 bytes
Ffuncall() line 2403 + 20 bytes
Fcall_interactively() line 675 + 17 bytes
Fcommand_execute() line 6904 + 17 bytes
command_loop_1() line 1371 + 29 bytes
internal_condition_case() line 1132 + 3 bytes
command_loop_2() line 994 + 21 bytes
internal_catch() line 907 + 7 bytes
command_loop() line 974 + 22 bytes
recursive_edit_1() line 755 + 5 bytes
Frecursive_edit() line 798
main() line 1004
mainCRTStartup + 196 bytes
_start() line 119